Centova and connection to server

#1
I'm trying to get a handle on exactly how this works and have hit a snag using Icecast2 and this Centova control panel.

The sound source that I'm using to upload our stream is in another location, and I want to be able to remotely turn our stream service on and off. We won't broadcast 24/7, just when we have audio from a live event to share so I haven't setup any autodj or any music files stored on the server.

I want to turn the "radio station" on and off via the Centova control panel and leave the source (laptop running Mixxx) on 24/7 in the remote location.

I tested this today and I can turn off the stream via Centova, but when I turn it back on my source is no longer connected.

What am I missing here?
 

Support

Level 1 Support
Staff member
#2
Hi Dvcat123,

Do you have the 'Enable Live Broadcasting' box permanently ticked in Mixxx's live broadcasting preferences? If not, then where you are turning off the server it is not automatically reconnecting the source when you then start the server again.
 
#3
OK. I went to the remote site and restarted the stream (including having to restart Mixxx to get it to connect). I toggled the stream on via the preferences rather than the drop down menu and it connected.

I then used Centova to stop the server (it did) and then told it to reconnect. Same issue, it doesn't connect and nothing is playing.
 
#4
Some more information ...

At some point when it wasn't working there was a message about "liquidsoap". I looked around and see that's the autoDJ software, hmm. I have AutoDJ disabled as I have nothing to broadcast when we're not live. Is that why stopping the server stops the connection to my uploading computer with Mixxx?

Do I need to setup a DJ account and then have an audio file looping when I'm not live (even if silence)? Remember, when the stream goes live I am not in the same location as the streaming laptop. I just want to be able to toggle things on and off by remote.

Perhaps I need a Barix Instreamer rather than use a laptop.
 

Support

Level 1 Support
Staff member
#5
Ok we see, we were not sure if perhaps the Mixxx software would just auto-reconnect when the server was started again. If this does not work then you are likely going to need to just manually reconnect the source at your remote location (which we appreciate is not want you want to achieve).

What is your server accounts username by the way Dvcat123?

The AutoDJ would have no effect on this as long as your source encoder software is connecting on the /live mount point in its settings (which automatically overrides the AutoDJ on the /stream mount). What mount are you currently connecting to with Mixxx?

May we ask why you leave the source on 24/7 in the remote location? Is there nobody that end who could connect this for you only when it is required to broadcast a live event?
 
#6
Settings are as per your video "Streaming with the Mixxx ..." video, mount= /live account is nevehshalompdx

Most of the events are regularly scheduled but I cannot be present for every event and I don't have a backup person to do this. I need to be able to either have it remain connected 24/7 and toggle the streaming server on and off with Centova, or get a different method of uploading to your server that I can remotely login to. For now I'd rather simply find a way to have the laptop software not disconnect when the streaming service is off.

Our events are live so we need an encoder solution that can take analog input from a fixed sound system, the "vinyl pass thru" option on Mixxx works fine.
 
#7
Sheesh, I keep replying to myself (no worries, I'm aware we're on opposite sides of the globe).

I did some research re Mixxx and got in way over my head. If you're a tech guru there's a developer thread on a closely related issue here

https://github.com/mixxxdj/mixxx/pull/1031

Apparently Mixxx is considering adding a reconnect to server setting dialog to the streaming preferences page, which confirms that the current version of Mixxx does NOT try to reconnect by itself if there is an interruption to the server. So my stopping the server is by default stopping Mixxx and the current version will not attempt to reconnect when the server restarts.

Is there a reason from your sever side to be concerned about a streaming encoder constantly trying to reconnect on it's own? It's interesting that the developers are concerned about annoying the streaming service providers.
 

Support

Level 1 Support
Staff member
#8
Right ok, we thought as much. That's a shame.

In this case we would recommend that you give Winamp and it's Shoutcast DSP plugin a try, that has such an "auto-reconnect" feature. But.. unfortunately you are running an Icecast server. So it might be worth you testing this with a Shoutcast server instead. https://www.internet-radio.com/comm...he-shoutcast-source-dsp-plugin-for-winamp.14/

We think an encoders auto-reconnect feature is a good thing, especially in case there is ever any network issues at the source end and nobody is around to reconnect the encoder. But yes, if an encoder is constantly sending login attempts to a server that could be an issue with some providers. We can appreciate your circumstances and reasons for this, but it is not the most ideal set up really.
 
#9
My source is running Linux Mint, so changing to Winamp won't work. I'll just deal with the issue for now while I wait to see if the changes are released for Mixxx, and/or consider a dedicated streaming device rather than a PC for sending the stream. Have you had any issues with Barix Instreamers and your service?
 

Support

Level 1 Support
Staff member
#10
Ok we see. You could be waiting a while for the changes to Mixxx to be honest!

As far as we are aware we do have one or two clients using the Barix Instreamers with our services and we cannot remember them having any issues. We have not personally ever used a Barix Instreamer ourselves before, so unfortunately we are not really in the position to give you any advice on configuring this we are are afraid. But you should not have any problems with doing so.
 
Top