Mount point not working, please help

#1
I have my remote pc and a server. When I try to stop my edcaster on the server and start my edcaster on the remote pc I can get them to connect but listeners must refresh to hear the stream again. I assume its because im using /live for the remote pc. the server uses ./live as a default. So I set up a mount point called /remote for the remote pc. edcaster connects to the /remote but listeners hear nothing, even if they refresh. What am I doing wrong?
 

Support

Level 1 Support
Staff member
#2
Hi Rich,

As you have Icecast servers then you should be connecting any live sources on the same /live mount point. The player and media player links on your startpage point to your /live mount. If a live source is not connected then this falls back to your default /stream mount point which is most cases people are running the AutoDJ feature on so therefore this would be the /autodj mount point. Listeners are then moved automatically between these mount points without any disconnections.

In this case as you had created a /remote mount point, then you would have to provide the listeners with the playlist link for that particular mount, so for example http://www.regionradio.live:8082/remote.m3u

So just stick with using /live for all live sources.
 
#3
Ok I did that. When all mount point are set to live the stream on the server works. When I stop the edcaster on the main server and start the remote pc, the remote only works if you refresh the stream. How can I get it to not disrupt what the listener hears?
 

Support

Level 1 Support
Staff member
#4
As there will always be a gap between switching live sources the best way around this would be to have some files (or a single file) playing on your accounts AutoDJ feature (on the /stream mount). That way there wouldn't be any gaps of silence and the listeners would also get moved automatically between the mount points without being disconnected (as mentioned above).
 
#5
It's not a gap of silence. It goes dead. It only comes back on if the listener refreshes the the page or source they are listening on.
 

Support

Level 1 Support
Staff member
#6
Yes we understand that. So by using the AutoDJ as a fallback it would prevent them having to refresh and "also" any gaps of silence.
 
#7
We have auto dj set up. It still goes silent. And you can not hear anything until you refresh. Going from our regular server to live or live back the the regular server. It will not play anything at all until we refresh.
 
#9
Which station are you looking at? I have tried this on our rock, country, all of them. We get the same result. Dead air, not just a gap. I can even have a song playing on the next setup and then switch, it will still go dead. I also dont want auto dj to come on during that point. I want the next stream to come on.
 

Support

Level 1 Support
Staff member
#11
We were looking at your 'rock' account as that was the one that we spotted had the /remote mount point set up.

Unfortunately you will continue to experience this unless you set up a fallback mount point, such as /autodj. Alternatively you could instead upload a fallback file to your /stream mount. That would prevent your listeners connections getting dropped when there is no source connection on /live or /autodj.

The fallback file can be an Mp3 of anything, maybe a station jingle or even just pure silence. Just make sure that it is encoded at the same bitrate / samplerate and number of channels as your live sources. That would probably work best for you here if you are not keen on using the AutoDJ feature, the fallback file just continually loops until a live source connection is established.
 
#12
ok i did what you said. It still did not work. The Auto DJ always locks out any of our servers. its why we had to disable them on other stations.
NOW ON TOP OF THAT the rock has no sound at all. I tried it on my pc, my phone, my wifes pc, my wifes phone, my friend tried his phone. NONE of us could hear the Rock station. All the other stations work fine. Rock is the only one not working. Is there anyone I can call to get this fixed.
 

Support

Level 1 Support
Staff member
#13
ok i did what you said. It still did not work. The Auto DJ always locks out any of our servers. its why we had to disable them on other stations.
That shouldn't happen! Icecast servers are designed to move listeners automatically, that is the whole point of them having mount points. Did you try using the fallback file method instead?

NOW ON TOP OF THAT the rock has no sound at all. I tried it on my pc, my phone, my wifes pc, my wifes phone, my friend tried his phone. NONE of us could hear the Rock station. All the other stations work fine. Rock is the only one not working. Is there anyone I can call to get this fixed.
As before, your start page player and media player links point to your /live mount point. You have renamed your default /stream mount point to /remote which we advised against previously. If you rename this back to /stream this will correct the issue. The stream is up and running but on your /remote mount point.
 
#14
I understand this should not happen. It's why I'm mad. My station has been down for 24 hours.
I did as you said and I even deleted the mount point /remote. None of our programs are set to it.
 

Support

Level 1 Support
Staff member
#15
Your server hasn't been down. You would have only been able to tune into it via http://www.regionradio.live:8082/remote that's all.

The /remote mount point still exists on your 'rock' account (unless you are referring to another account?). Also when you rename this back to /stream make sure that you fully stop and restart the server for the change to take full effect.
 
#16
It's been down since Yasser afternoon because I gave up trying. Even friends gave up helping. I had everything set back to the way it was days ago when it worked and still nothing.

Is there a phone number to call in situations like this?
Also I deleted all mount points on the rock station thinking I created them wrong. We been using the /live mount point from day 1. I just switched it to /stream and it works. I do not have a /stream mount point created. Are /live and /stream default mountpoints?

I appreciate all your help during this entire situation.
 

Support

Level 1 Support
Staff member
#18
I've just corrected this on your 'rock' account for you and renamed /remote back to /stream.

Your servers default mount point is /stream. A /live mount points also exists by default but this isn't ever displayed on the mount point list. But /live is the mount that you connect any live sources to.

Unfortunately, we are afraid that at the moment that we do not offer telephone support as this would mean us having to get a premium rate phone line installed and therefore increase our server prices. Also, we are UK based and you are US based, so the time difference could be an issue at times.

Yes I have just seen the notification emails that you have been exceeding your accounts bitrate limit. You have 128kbps set as your maximum bitrate under your servers configuration 'Limits' tabs settings but it seems as though you are trying to connect a live source encoding at 256kbps. You can set this up to 320kbps, so we recommend that you do so to prevent this from happening again.
 

Support

Level 1 Support
Staff member
#20
You would have received the bitrate exceeded emails to your accounts registered email address. But here is a copy of the recent email:

rock,

This message is to inform you that you have been broadcasting at a bit rate of 256 kbps, while the bit rate limit for your account is only 128 kbps.

Your streaming server has been stopped to terminate your broadcast at this bit rate. Please adjust your streaming source settings to use a bit rate of no more than 128 kbps, then login to your control panel and use the "Start Server" button to restart your streaming server.

If you require assistance, please contact the support department.
Here is your 'Limits' settings in the control panel:

limits.png
 
Top