web player confusion (upgraded account)

dooly

New Member
#1
Hi,
I upgraded to the 500GB plan a while back, and I restarted my server several times since, but when I get up to 5 simultaneous on the internet-radio.com page (by html5player), it skips.
The start page (https://www.internet-radio.com/station/knklsturgis/) has:
Code:
'http://us4.internet-radio.com:8223/listen.pls'
as the jplayer target, but the info in the widget section says my html5 player code target is
Code:
'https://control.internet-radio.com:2199/system/player.js'.
by the java code it wants me to place in the bottom of the page:
Code:
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/player.js"></script>
Btw, the web player never worked in the centnova. Right now, my web page ( knkl.net ) is using a shoutcast stream for the html5 (since it always worked), but I will be discontinuing that streaming server in Sept. So, I need this straighten out so I can transition totally out from shoucast's streaming host.


Thanks
 

Support

Level 1 Support
Staff member
#2
Hi Dooly,

The player widget code has two parts that you need to use. The second part of the code that you place at the bottom of your web page just before your </body> tag just provides the players functionality. It is the first part of the code
<div class="cc_player" data-username="knklsturgis">Loading ...</div>
which points to your user account ("target").

But yes your start pages player points to your servers stream url of http://us4.internet-radio.com:8223/, but that is irrelevant to the HTML5 widget code that you need to use for your own website.

You currently have the player option set to the Flash player (Muses) in your settings, we have just changed this to the HTML5 jPlayer for you instead and it works fine when you test the preview.

Sorry to hear that you had some issues with the stream skipping when you hit 5 listeners. As the 5 listener limit is what comes with our free trial accounts, after you upgraded this to the 500GB plan did you do a full hard stop and restart on the server at all? It may have been the case this was needed for the new plans configuration to take full effect. We have just done this for you anyway so let us know how you get on now, cheers.
 

dooly

New Member
#3
Thanks, What ever you did, the "preview" window works now, Yes, i know the Jplayer is two parts, its just that when port 2199 wasn't working with the jplayer, and the only way it was working was when I changed it to port 8223 (which made me think something wasn't correct somewhere), Thanks for sorting things out for me, now I can transition out of shoucast's hosting. You might want to look into the way the player is switching types (jplayer vs. muses) because I tried it both ways, but I don't remember restarting the server after the change (which might be needed and maybe a reboot needs to be automated via script on the server end when the changes are applied)
Screenshot from 2018-07-02 09-22-58.png
 

Support

Level 1 Support
Staff member
#4
You're welcome. It previously previewed the Flash player instead. But if you do not have Flash installed on your PC or enabled for your web browser then this would not have displayed correctly. It worked for me personally but I switched it over to the HTML5 player instead for you as you mentioned that is what you required. It does not require a full server restart to change the player over for the widgets. A full restart is only required for any main configuration setting changes.

Port 2199 is the main control panel port number by the way, not your own accounts port number which as you know is 8223. So the code points to your accounts username but the player is hosted on our main control panel server itself which is a different server to which your account is hosted on. So we hope that makes sense as to why the code uses port 2199.
 
Top