Network error: timeout getting IP address

#4
Solution found

Firstly, thank you for the replies.
When the fault occurred I rang Roberts and was told to Upgrade Firmware. No effect. I tried Factory Reset. No effect.
My nextdoor neighbour kindly fixed the problem for me. This is an outline of the procedure he used:
On my computer Start/Programs/Accessories/Command Prompt
Type in ipconfig/all - enter
Then copy some of the settings - these are my values:
IP Address - 192.168.0.7 (Apparently this has to be unique, so he chose the 7)
Subnet mask - 255.255.255.0
Default gateway - 192.168.0.1
DNS server - 192.168.0.1
Then go to the Roberts menu: Settings/Network/Edit Config and enter these values. After carrying out this procedure my radio started working again.
Many thanks to dogmatix for his explanation of the fault. He agreed that the cause was a power cut. When the power is restored the internet radio starts up faster than the router, and so gets no answer to its request for an IP address. The procedure that I have described uses a fixed address and therefore cuts out the IP address request stage.
 
#6
I had this problem a couple of years ago in France. We were just about to come home so brought the radio back and connected to internet there and on return to France radio connected ok so I thought good, it needs to connect before it can reconnect. However, just happened again when I accidentally unplugged the radio so I found this thread. Oh no, I thought, do I really have to press all those buttons? Then I saw the bit about the radio connecting quicker than the router, so I thought, how about, with the radio already plugged in, switching the router off and back on? And voilà! It worked! Engineer's reset triumphs again!
 
Top