Latest Chrome browser update (v55) breaks Shoutcast v1.x HTML5 players

More Support

Level 2 Support
Staff member
#21
Good News! It appears the Chrome team has decided to roll back the change:

After much discussion and looking at how many users this impacts, we plan on re-enabling HTTP/0.9 over ports other than 80 for Chrome 56. We'll remove it again in Chrome 57, but we'll also add a hack to allow it just for responses that look to be from Shoutcast servers (Ones that start with "ICY"). So behavior should be just like it was in Chrome 54 and earlier going forward, for Shoutcast servers (Worth noting this does not quite match FireFox's current behavior).
https://bugs.chromium.org/p/chromium/issues/detail?id=669800#c103

We still recommend upgrading to ShoutCast 2 though as shoutcast.com will likely remove version 1 stations at some point. We're not sure on the status of other browsers in the future either.
 

Gel

New Member
#22
Last few days my 3 browsers won't stream from smoothjazzflorida url; No Web Player showing where play button should show. "Flash" functionality checked and that works fine. :( Tried multiple refreshes but still won't work.
 

Support

Level 1 Support
Staff member
#23
Last few days my 3 browsers won't stream from smoothjazzflorida url; No Web Player showing where play button should show. "Flash" functionality checked and that works fine. :( Tried multiple refreshes but still won't work.
Hmmmm strange? It's working fine for us. We suggest perhaps try clearing your browsers cache and try again!
smoothjazzflorida.png
 

Support

Level 1 Support
Staff member
#26
IE11/ AVANT /Edge
IE11/ Edge are rubbish in our opinion.. We think it's time that you moved to a better browser such as Chrome/Firefox. We cannot really help you much more with this as it is working fine for us (and others) and the previous Chrome update issue this thread relates to has since been rolled back in their latest update. I just tested this again in the Edge browser and it's still working as it should. By the way the player we use is HTML5, not Flash.

Pretty sure if you cleared the browsers cache's or tested this in a private window this will work for you.
 
#27
Is there any reason why this error would show up in Firefox if my station (Shadowy Realms) is a v2 Shoutcast station? The station is HTML5 friendly, as is evidenced by the functional HTML5 player on the station home page (www.shadowyrealms.com).
 

Support

Level 1 Support
Staff member
#28
Is there any reason why this error would show up in Firefox if my station (Shadowy Realms) is a v2 Shoutcast station? The station is HTML5 friendly, as is evidenced by the functional HTML5 player on the station home page (www.shadowyrealms.com).
Hi Pilgrim,

Your station is working fine for us in Firefox. We recommend just clearing your browsers cache and trying again or trying another web browser instead.

shadowyrealms.png
 
Top